When will UnionPay deposits be working again?

thornythorny Posts: 38 Tin ✭
I recently tried to make a deposit using Internet Explorer v.11 on Windows 10. It didn't work. Not only doesn't the site work well at all on IE, the China UnionPay deposit function doesn't work when you finally get to it.

I'm on page 3 for deposit amount and it's showing USD. There is no dropdown menu to change the currency. To save time, I logged in on Firefox v. 49 I think, and tried again. I got to step 3 and again got USD only. I went back to the dashboard, changed the currency at the top of the page, navigated through to step 3 again, and this time got HKD only.

So then I checked other payment methods such as Credit/Debit card, navigated through to step 3, and got a dropdown menu to choose a variety of currencies that included CNY. So then I went back to the dashboard, navigated through the UionPay option to step 3, and got only USD again.

Now if I enter say $90.00, I get an error message saying the amount must be larger than 100 CNY. So enter $100, and it says that's the wrong currency. I enter $500, and see 11 grams of gold. I can get 11 grams of gold with 500 USD, but not 500 CNY. So, what's the problem with the UnionPay method? I'm seeing USD, it's calculating my purchase with USD, but it's giving me error messages for CNY. What?

So the problem seems to be back at GoldMoney somewhere. I get the same problem with both IE and FF. When will this be fixed?

Also, I have to use IE to make deposits, because it's the only browser my bank supports. I need to be logged into GM and my bank in IE in order to make deposits. Everything else I can do in other browsers. So this problem needs to be fixed in IE as well as FF for residents of China.

Comments

Sign In or Register to comment.