Process flow/user experience improvement. Clicking buttons should take you to next step directly.

mr1mr1 Posts: 375 Silver ✭✭✭✭
I have a suggestion for improving some of process flow and user experience on on the site. In several places, such as after clicking on "Deposit", you are presented with buttons giving options of what you'd like to choose (such as Bank Transfer or Credit/Debit Card). Currently, you must click on the button and then click again on the "Next" button. However, the next button seems redundant in this case. I think it would be much nicer to be taken to the next page directly upon clicking on of the buttons.

Thanks!

Comments

  • paddy10tellyspaddy10tellys Posts: 249 Bronze ✭✭✭
    @mr1 agreed. Poor Ux causes brand irritation. Other causes are the glacial response times by the overstretched support team (?person) assigned to us oiks in Goldmoney personal. Flashy it ain't but it works (eventually) & it's cheap. Early days for a company running tight margins who will evolve & improve on a solid underlying proposition
  • EJMoosaEJMoosa Posts: 2 Tin ✭
    I have to agree with the sentiment. I started the process a few weeks ago. Could not upload id from the app. Then there are no status updates. Today I go online and it tells me I need to give the last four of my SSN, and now a third party is reviewing my ID. As much as I want this to work, the level of discomfort continues to grow.
  • TauntFourstarTauntFourstar Posts: 218 Bronze ✭✭✭
    @EJMoosa not sure why you need your last 4. I have only had to upload photo ID. This is the most PPI they have for me...
  • mr1mr1 Posts: 375 Silver ✭✭✭✭
    @TauntFourstar and @EJMoosa
    I also had to give the last 4 of my SSN but I can't remember exactly which step it was at. I think that was while trying to connect my bank account.
    And I think I also could not get the app to take a picture of my ID for me so I had to take a picture on my own and save it to my computer then upload using the full site. Then I had to wait to have my ID reviewed, but it sounded like that was the normal process and only took a day or two I think.
  • mr1mr1 Posts: 375 Silver ✭✭✭✭
    @Melanie
    Just to let you know, it looks two people here in this thread (myself and @EJMoosa ) seemed to have trouble uploading our ID using the app. My app just wouldn't respond when I tried to press the button to take a picture (I'm on Android). I was able to work around the issue by using the desktop site, but seems like there might be a bug somewhere in the app that should be looked into.
  • TauntFourstarTauntFourstar Posts: 218 Bronze ✭✭✭
    edited January 2017
    @mr1 There is a bug in the app to upload id @Melanie ... Hopefully someone can fix that soon otherwise the other option for your phone is to just go to the website In a browser and upload your photo ID there. I have a Windows Phone and it seems to work just fine using the browser.
    good thing the website works that you were able to get that taken care of
Sign In or Register to comment.