Cannot Navigate to Redeem

I'm trying to migrate from the bitgold vaults to the Holdings, and none of the links under 'Navagation' work for me. Clicking any link does nothing at all. I'm looking to redeem, and although the balance says zero, I have never removed any gold from the vault. I received an email response from support, but I'm still having problems navigating to Redeem and Migrate the account to to the new setup. I use Firefox browser. Any ideas?

Answers

  • RedeemerRedeemer Posts: 1 Tin ✭
  • eghbeghb Posts: 2 Tin ✭
    I have tried emailing support, and one tells me that I am fully verified. The webssite allows me to logon to my personal account, but once I click "Redeem" I get this message "Holding Is Not Verified" "The holding is not verified". I tried password recovery, but I am getting the same result.
    If there is something else that I need to do to allow redeeming, can someone let me know. I do want to get out, but I am put off by current problems. I did not get to switch to holdings earlier, and that was my fault. If I ask for physical delivery, can I expect this to be problem free?
  • RocketDogRocketDog Posts: 598 Silver ✭✭✭✭
    Physical delivery has worked well for me as long as the gold/silver was in stock. If not in stock, there can be huge delays, and they won't necessarily contact you to tell you why. If you are not verified, they probably won't let you redeem for physical anyway. I wish you luck.
Sign In or Register to comment.